mozdev.org

Mozdev CVS Repository

CVS log for dict/install.rdf.m4

[BACK] Up to [mozdev] / dict

Request diff between arbitrary revisions - Display revisions graphically


Keyword substitution: kv
Default branch: MAIN


Revision 1.35: download - view: text, markup, annotated - select for diffs
Mon Dec 9 01:32:11 2013 UTC (3 years, 11 months ago) by dcostanz
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.34: preferred, colored
Changes since revision 1.34: +1 -1 lines
Fix the maxVersion for SeaMonkey, as suggested when I tried to upload the 0.7.3 version to addons.mozilla.org.

Revision 1.34: download - view: text, markup, annotated - select for diffs
Sun Dec 8 17:31:16 2013 UTC (3 years, 11 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.33: preferred, colored
Changes since revision 1.33: +2 -2 lines
Update the max version of the supported applications to include what's on my Fedora box.

Revision 1.33: download - view: text, markup, annotated - select for diffs
Sat Nov 30 03:10:58 2013 UTC (3 years, 11 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.32: preferred, colored
Changes since revision 1.32: +9 -0 lines
Mark as compatible with SeaMonkey.

Revision 1.32: download - view: text, markup, annotated - select for diffs
Sun Sep 8 04:11:28 2013 UTC (4 years, 2 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.31: preferred, colored
Changes since revision 1.31: +1 -1 lines
fix a problem with the minVersion set for Thunderbird

Revision 1.31: download - view: text, markup, annotated - select for diffs
Mon Sep 2 20:43:23 2013 UTC (4 years, 2 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.30: preferred, colored
Changes since revision 1.30: +2 -4 lines
Get the Dict extension to work on Thunderbird, again.

Revision 1.30: download - view: text, markup, annotated - select for diffs
Tue Jun 18 02:32:53 2013 UTC (4 years, 5 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.29: preferred, colored
Changes since revision 1.29: +1 -1 lines
Include Firefox 16 in the supported versions so that Michael1972 can benefit from the fix for bug #25461.

Revision 1.29: download - view: text, markup, annotated - select for diffs
Mon Jun 10 02:10:53 2013 UTC (4 years, 5 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.28: preferred, colored
Changes since revision 1.28: +4 -4 lines
Remove vestigial support for the long-defunct Mozilla suite.  Change Firefox support to only version 21, which is all I intent to test on.

Revision 1.28: download - view: text, markup, annotated - select for diffs
Tue Feb 19 00:41:20 2013 UTC (4 years, 9 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.27: preferred, colored
Changes since revision 1.27: +4 -1 lines
Fix warnings from Mozilla's automated extension tests, which was mostly specifying in the install.rdf that this is an extension and removing the internal JAR file, which hasn't been required since Firefox 3.0.

The bulk of this fix was to move files from src/content/dict/* to content/* and from src/locale/en-US/dict to locale/en-US.  Unfortunately, CVS does not support file moving, so the change was to remove the files from the old location and add them to the new location.  This comment is provided in case you want to chase down the revision history.

Revision 1.27: download - view: text, markup, annotated - select for diffs
Mon Feb 18 04:48:15 2013 UTC (4 years, 9 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +1 -1 lines
Mark as compatible with FIrefox 18.

Revision 1.26: download - view: text, markup, annotated - select for diffs
Sun Sep 4 05:07:44 2011 UTC (6 years, 2 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +1 -17 lines
dict-6.82.0 - mark as compatible with Firefox 7.*.  Drop support for defunct Mozzila suite.

Revision 1.25: download - view: text, markup, annotated - select for diffs
Sun Dec 19 03:08:55 2010 UTC (6 years, 11 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +1 -1 lines
Mark as compatible with Firefox 4.0.

Revision 1.24: download - view: text, markup, annotated - select for diffs
Mon Jun 21 06:43:20 2010 UTC (7 years, 5 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +1 -1 lines
Increase the version to 0.6.79 and mark as compatible with Thunderbird 3.1.

Revision 1.23: download - view: text, markup, annotated - select for diffs
Sun Dec 27 05:55:56 2009 UTC (7 years, 10 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +1 -1 lines
Make compatible with Thunderbird 3.

Revision 1.22: download - view: text, markup, annotated - select for diffs
Sun Nov 15 18:39:24 2009 UTC (8 years ago) by dcostanz
Branches: MAIN
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +1 -1 lines
Mark Dict as compatible with Firefox 3.6.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Fri Mar 20 16:09:32 2009 UTC (8 years, 8 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +1 -1 lines
Mark as compatible with Firefox 3.5.  I have run through the full set of regression tests with Firefox 3.1 Beta 3 (Firefox 3.1 is being renamed to 3.5).  Note that the tests did not pass with Firefox 3.1 Beta 2, due to a bug in window.sizeToContent().

Revision 1.20: download - view: text, markup, annotated - select for diffs
Sun Sep 21 03:46:38 2008 UTC (9 years, 2 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-75
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +1 -1 lines
Mark Dict as compatible with FF 3.0.1.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Fri Jul 4 18:50:59 2008 UTC (9 years, 4 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +1 -1 lines
Mark as compatible with Firefox 3.0 and bump the version to 0.6.74.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sat Apr 5 23:10:43 2008 UTC (9 years, 7 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +1 -1 lines
Add Firefox 3.0pre as the max version so that Dict can be installed on all release candidates.

Revision 1.17: download - view: text, markup, annotated - select for diffs
Sun Mar 23 07:04:19 2008 UTC (9 years, 8 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +1 -1 lines
Make Dict compatible with Firefox 3B4.  This involved using a nsIWindowMediator to create the window that holds the definition, instead of using window.open().

This has the pleasant side-effect of getting rid of the "about:blank" and the "Mozilla Firefox" in the window titlebar.

Revision 1.16: download - view: text, markup, annotated - select for diffs
Mon Jan 7 03:16:31 2008 UTC (9 years, 10 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
Bump the version to 0.6.72 and make DICT compatible with Firefox 3 Beta 2 and Thunderbird 2.0.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Mon Oct 2 06:17:20 2006 UTC (11 years, 1 month ago) by dcostanz
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +1 -1 lines
Bump the min version for firefox to 1.0 because update.mozilla.org no longer accepts min version below 1.0.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Oct 2 05:17:07 2006 UTC (11 years, 1 month ago) by dcostanz
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +1 -1 lines
Add support for Firefox 2.0.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Thu Feb 2 05:02:36 2006 UTC (11 years, 9 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Release version 0.6.70, which will install on Firefox 1.5.0.1 and Thunderbird 1.5.

There are no bug fixes or new features for this release.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sun Dec 11 01:23:13 2005 UTC (11 years, 11 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-14
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
Release version 0.6.14.
This is a VERY minor release.
It just changes some things to make Dict conform to the requirements for hosting an extension on UMO.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sat Sep 24 21:15:26 2005 UTC (12 years, 2 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-13
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +1 -1 lines
Bump the version to 0.6.13.

This version marks Dict as compatible with Thunderbird 1.5.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Sep 17 20:05:20 2005 UTC (12 years, 2 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-12, dict-0-6-11
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +1 -1 lines
Mark that Dict supports Firefox 1.5.

I hesitated to do this because there's currently a bug in Dict (or Firefox) where
it doesn't handle international words properly on Firefox 1.5 beta 1, but
someone has already posted instructions on how to unpack Dict to make it installable
on Firefox 1.5 Beta, and I'd rather that they use offical installs.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Wed Jun 1 15:12:35 2005 UTC (12 years, 5 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-9, dict-0-6-8, dict-0-6-7, dict-0-6-10
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +1 -1 lines
Update to Dict version 0.6.7.

This makes Dict compatible with Firefox 1.1 (tested on Firefox 1.0+ "Deer Park").

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Feb 27 08:38:20 2005 UTC (12 years, 8 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-5, dict-0-6-4, dict-0-6-3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +8 -0 lines
Add an entry for the Mozilla Suite.

The Mozilla Suite doesn't use Extension Manager, but this is a requirement for all extensions listed on updates.mozilla.org.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Jan 22 19:48:27 2005 UTC (12 years, 10 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-2, dict-0-6-1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +1 -1 lines
Shorten the description so that it fits on the Extension Manager window.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Jan 22 18:54:34 2005 UTC (12 years, 10 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +1 -1 lines
Clarify the description.

Replace "define word" with "lookup word in online dictionary".
The Dict extension does not assign meaning to anything, it looks
up the assigned meaning.

Replace "word in a Web page" with "selected word", because the
Dict extension supports Thunderbird and Mozilla Composer.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Jan 19 19:10:02 2005 UTC (12 years, 10 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-6-0, dict-0-5-22
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +10 -0 lines
Add a block that says it's okay to install this extension in Thunderbird 1.0.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sun Oct 24 23:24:12 2004 UTC (13 years, 1 month ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-5-20, dict-0-5-18, dict-0-5-16, dict-0-5-14, dict-0-5-12
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
Bump the max supported version to 1.0 (I have tested this release on
a nightly build).

I have kept the minVersion at 0.7, even though I have not tested the
extension on version 0.7--it's just too much effort.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Sep 26 04:23:17 2004 UTC (13 years, 2 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +1 -1 lines
Add an updateURL to point to the update.rdf file.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Sep 26 02:05:55 2004 UTC (13 years, 2 months ago) by dcostanz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +1 -1 lines
Bump the max version to 0.10.  I have tested it with Firefox 1.0 PR.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun Jun 20 02:18:19 2004 UTC (13 years, 5 months ago) by dcostanz
Branches: MAIN
CVS tags: dict-0-5-6
Add an M4 template for install.rdf, which is needed to support Firefox 0.9.

This is basically a port of install.js.m4

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>