Annotation of aphrodite/www/installation.html, revision 1.66

1.3       petejc      1: <script language="javascript">
                      2: <!--
                      3: 
                      4: function triggerURL(url) {
                      5: 
1.45      petejc      6:        const MAC     = "Mac";
1.55      john        7:        const MSG         = "Sorry, Aphrodite doesn't work on the mac";
1.3       petejc      8: 
1.45      petejc      9:        var platform    = navigator.platform;
1.3       petejc     10: 
1.57      petejc     11:        if(platform.match(MAC)) {
1.45      petejc     12:        alert(MSG);
                     13:                return null;
1.57      petejc     14:        }       else {  
1.45      petejc     15:        if (!InstallTrigger.updateEnabled())
                     16:                return false; 
                     17:        else 
                     18:                InstallTrigger.startSoftwareUpdate(url); 
                     19:        }
                     20: 
                     21:        return true;
1.3       petejc     22: }
                     23: 
                     24: //-->
                     25: </script>
                     26: 
1.21      petejc     27: <!-- MAIN CONTENT -->
1.55      john       28: <h5 class="page-header">Installation</h5>
                     29: 
1.65      petejc     30: Page Last Modified: <?php getFileDate("/installation.html"); ?>
1.59      petejc     31: 
1.57      petejc     32: <pre>
1.60      petejc     33: <b>Note:</b> The "Latest Build" of Aphrodite should work w/ Mozilla 1.x. 
1.59      petejc     34: 
1.62      petejc     35: <b>Aphrodite works w/ phoenix and mozilla</b>
1.63      petejc     36: To run using the phoenix binaries:
                     37: 
                     38: $ ./phoenix -chrome chrome://aphrodite/content/install.xul # this installs Aphrodite
                     39: 
                     40: $ ./phoenix -chrome chrome://aphrodite/content/ # subsequent launches
                     41: 
1.62      petejc     42: 
1.59      petejc     43: It is suggested that developers only play w/ Aphrodite since it is 
1.61      petejc     44: a far way off from being a usable browser due to lack of time to work on the project.
1.65      petejc     45: 
                     46: If you are upgrading from a recent version of Aphrodite, make sure you clear out you cache first
                     47: otherwise the xpi package may be pulled from there. This is a problem i ran into.
1.57      petejc     48: 
1.59      petejc     49: --pete
1.57      petejc     50: 
                     51: </pre>
1.59      petejc     52: 
1.52      john       53: <br>
                     54: 
1.60      petejc     55: <i>(If there are any problems installing this package, please <a href="mailto:aphrodite_hackers@mozdev.org">contact us</a>.)</i>
1.52      john       56: <br>
                     57: <br>
1.33      david      58: 
1.41      david      59: <p><b>Note:</b> You must have javascript enabled in order to install from the links below.
1.52      john       60: <br>
                     61: <b>Aphrodite doesn't work on the mac</b>. It will in future versions.
                     62: <br>
                     63: <br>
                     64: <br>
1.42      david      65: 
1.27      david      66: <ul>
1.60      petejc     67: <!--
1.42      david      68: <li>To install the <b>stable release version</b> of Aphrodite 0.05 launch either <b>Mozilla M18</b> or <b>Netscape 6</b>,
1.41      david      69: return to this page and click on this link to install the official
                     70: <a href="#" onclick = "triggerURL('http://aphrodite.mozdev.org/aphrodite_0_05_snap.xpi');">Aphrodite 0.05</a> release.<br><br>
                     71: 
1.60      petejc     72: <li>After you install Aphrodite, quit Mozilla and restart it. Go to the Tasks menu and click Finish Aphrodite Install. You need only do this once.  Close and restart Mozilla again.<BR><BR>
1.51      john       73: 
1.60      petejc     74: <li>Launch Aphrodite from Mozilla's Tools menu.
1.52      john       75: <br>
                     76: <br>
                     77: <hr>
                     78: <br>
1.60      petejc     79: -->
1.52      john       80: 
1.60      petejc     81: <li>the <b>development version</b> of Aphrodite 0.6 is targeted for Mozilla 1.x and developers.
1.51      john       82: 
1.60      petejc     83: <li>To install the <b>development version</b> of Aphrodite 0.6 click on the following link using Mozilla.
1.66    ! petejc     84: 
1.60      petejc     85: <a href="#" onclick = "triggerURL('http://aphrodite.mozdev.org/xpi/aphrodite_current_static.xpi');">
1.66    ! petejc     86: <b>Install The Latest Build of Aphrodite</b></a>
1.27      david      87: 
1.51      john       88: <li>After you install Aphrodite, quit Mozilla and restart it. Go to the Tools menu and click Finish Aphrodite Install. You need
1.52      john       89: only do this once.  Close and restart Mozilla again.<br><br>
1.3       petejc     90: 
1.52      john       91: <li>Launch Aphrodite from Mozilla's Tools menu.
1.2       david      92: 
1.64      petejc     93: <li><i>If you still have problems please check out the <a href="http://aphrodite.mozdev.org/faq.html">FAQ</a>.</i>
1.27      david      94: </ul>

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>