Diff for /aphrodite/www/installation.html between versions 1.21 and 1.60

version 1.21, 2000/09/29 15:10:16 version 1.60, 2002/10/06 23:45:50
Line 3 Line 3
   
 function triggerURL(url) {  function triggerURL(url) {
   
        if (!InstallTrigger.updateEnabled()) {        const MAC     = "Mac";
        return false; }        const MSG         = "Sorry, Aphrodite doesn't work on the mac";
   
        else {        var platform    = navigator.platform;
   
        InstallTrigger.startSoftwareUpdate(url); }        if(platform.match(MAC)) {
         alert(MSG);
                 return null;
         }       else {  
         if (!InstallTrigger.updateEnabled())
                 return false; 
         else 
                 InstallTrigger.startSoftwareUpdate(url); 
         }
   
           return true;
 }  }
   
 //-->  //-->
 </script>  </script>
   
   
 <!-- MAIN CONTENT -->  <!-- MAIN CONTENT -->
<p>*Note* 9/29/00 Aphrodite Nightly is back working again.<h5 class="page-header">Installation</h5>
You need to create dir and a file in your mozilla home directory if it is not there already. The directory name is "chrome" and the file name is "user-skins.rdf". 
 Last Modified: <?php getFileDate("/installation.html"); ?>
 
 <pre>
 <b>Note:</b> The "Latest Build" of Aphrodite should work w/ Mozilla 1.x. 
 
 It is suggested that developers only play w/ Aphrodite since it is 
 a far way off frome being a usable browser due to lack of time to work on the project.
 
 --pete
 
 </pre>
 
 <br>  <br>
 Here is what mine looks like:   
   
<font size=-1><i>(If there are any problems installing this package, please <a href="mailto:aphrodite_hackers@mozdev.org">contact us</a>.)</i>
<xmp><br>
<?xml version="1.0"?><br>
<RDF:RDF
     xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#"><p><b>Note:</b> You must have javascript enabled in order to install from the links below.
  <RDF:Description about="urn:mozilla:package:global"><br>
    <NS16:selectedSkin xmlns:NS16="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:modern/1.0:global"/><b>Aphrodite doesn't work on the mac</b>. It will in future versions.
  </RDF:Description><br>
  <RDF:Description about="urn:mozilla:package:chatzilla"><br>
    <NS17:selectedSkin xmlns:NS17="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:modern/1.0:chatzilla"/><br>
  </RDF:Description> 
  <RDF:Description about="urn:mozilla:package:editor"> 
    <NS18:selectedSkin xmlns:NS18="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:modern/1.0:editor"/> 
  </RDF:Description> 
  <RDF:Description about="urn:mozilla:package:messenger"> 
    <NS19:selectedSkin xmlns:NS19="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:modern/1.0:messenger"/> 
  </RDF:Description> 
  <RDF:Description about="urn:mozilla:package:communicator"> 
    <NS20:selectedSkin xmlns:NS20="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:modern/1.0:communicator"/> 
  </RDF:Description> 
  <RDF:Description about="urn:mozilla:package:navigator"> 
    <NS21:selectedSkin xmlns:NS21="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:modern/1.0:navigator"/> 
  </RDF:Description> 
  <RDF:Description about="urn:mozilla:package:theme_builder"> 
    <NS22:selectedSkin xmlns:NS22="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:theme_builder/:theme_builder"/> 
  </RDF:Description> 
  <RDF:Description about="urn:mozilla:package:aphrodite"> 
    <NS23:selectedSkin xmlns:NS23="http://www.mozilla.org/rdf/chrome#" resource="urn:mozilla:skin:aphrodite/:aphrodite"/> 
  </RDF:Description> 
</RDF:RDF> 
</xmp> 
</font> 
 
<P><B>Installation</B><BR> 
 
<I>(If there are any problems installing this skin, please <a 
href="mailto:feedback@mozdev.org">contact us</a>.)</I> 
 
<UL> 
 
<i><b>Note:</b> Aphrodite will not run on M17.  To find out more about why, read the <a href="faq.html">FAQ page</a>.</i><BR><BR> 
 
<li>To install the latest <b>stable version</b> of Aphrodite: launch <b>M16</b>, return to this page and click on this link 
to <a href="#" onclick = "triggerURL('http://aphrodite.mozdev.org/aphrodite_0.04.xpi');">install Aphrodite 0.04</a>.  A 
dialog box will appear and click OK to install.<BR><BR> 
 
<li>To install the latest <b>development version</b> of Aphrodite: launch <b>M18</b>, return to this page and click on this 
link to <a href="#" onclick = "triggerURL('http://aphrodite.mozdev.org/aphrodite_current.xpi');">install Aphrodite 
nightly build</a>.<BR><BR> 
 
<LI>On <B>Windows</B>, launch Mozilla <!-- or Netscape 6--> at the DOS 
prompt with:<BR> 
<TT><!--(Mozilla) -->mozilla.exe -chrome chrome://aphrodite/content/</TT><BR> 
<!-- <TT>(Netscape 6) netscp6.exe -chrome chrome://aphrodite/content/</TT>--> <BR> 
   
 <P>On <b>Windows</b>, it's also possible to launch the skin from an icon on your desktop.<BR><BR>  
 <ul>  <ul>
<li>Right click on the Mozilla icon<!--or Netscape 6 icon--> and select Properties.  <!--
<li>In the Target area of the Properties box, add the following at the end of the line:<br><li>To install the <b>stable release version</b> of Aphrodite 0.05 launch either <b>Mozilla M18</b> or <b>Netscape 6</b>,
<tt>&nbsp;-chrome chrome://aphrodite/content/</tt>return to this page and click on this link to install the official
<li>It should now look similar to<a href="#" onclick = "triggerURL('http://aphrodite.mozdev.org/aphrodite_0_05_snap.xpi');">Aphrodite 0.05</a> release.<br><br>
 
<a href="http://www.metafilter.com/trash/alphanumerica/nn6-after.gif">this 
screenshot</a>. <SMALL>(Thanks to <A HREF="http://www.metafilter.com/">Matthew 
Haughey</A> for sending this.)</SMALL><BR><BR> 
   
</ul><li>After you install Aphrodite, quit Mozilla and restart it. Go to the Tasks menu and click Finish Aphrodite Install. You need only do this once.  Close and restart Mozilla again.<BR><BR>
   
<LI>On <B>Unix</B>, launch Mozilla <!--or Netscape 6--> with:<BR><li>Launch Aphrodite from Mozilla's Tools menu.
<TT><!-- (Mozilla)-->% ./mozilla -chrome chrome://aphrodite/content/</TT><BR><br>
<!-- <TT>(Netscape 6) % ./netscape -chrome chrome://aphrodite/content/</TT>--> <BR><br>
 <hr>
 <br>
 -->
 
 <li>the <b>development version</b> of Aphrodite 0.6 is targeted for Mozilla 1.x and developers.
 <br>
 <br>
 
 <li>To install the <b>development version</b> of Aphrodite 0.6 click on the following link using Mozilla.
 <br>
 <br>
 <a href="#" onclick = "triggerURL('http://aphrodite.mozdev.org/xpi/aphrodite_current_static.xpi');">
 Install The Latest Build of Aphrodite</a>
 <br>
 <br>
 
 <li>After you install Aphrodite, quit Mozilla and restart it. Go to the Tools menu and click Finish Aphrodite Install. You need
 only do this once.  Close and restart Mozilla again.<br><br>
 
 <li>Launch Aphrodite from Mozilla's Tools menu.
 <br>
 <br>
   
   <li><i>If you still have problems please check out the <a href="http://aphrodite.mozdev.org/faq.html">FAQ</a>.</i><br><br>
 </ul>  </ul>

Removed from v.1.21  
changed lines
  Added in v.1.60


FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>