Annotation of annozilla/src/makefile, revision 1.12

1.12    ! matthew     1: XPI = ../downloads/annozilla-latest.xpi
        !             2: 
1.9       matthew     3: SOURCE = content/annozilla/* \
                      4:          content/annozilla/about/* \
                      5:          content/annozilla/editor/* \
                      6:          content/annozilla/icons/* \
                      7:          content/annozilla/prefs/* \
                      8:          content/annozilla/prefs/firefox/* \
1.10      matthew     9:          locale/en-US/annozilla/* \
                     10:          locale/fr-FR/annozilla/*
1.1       matthew    11: 
1.8       matthew    12: COMPRESS = perl zip.pl
                     13: 
1.12    ! matthew    14: xpi: versioncheck install.js install.rdf chrome/annozilla.jar
        !            15:        $(COMPRESS) $(XPI) install.js install.rdf chrome/annozilla.jar
1.1       matthew    16: 
1.6       matthew    17: chrome/annozilla.jar: $(SOURCE)
1.11      matthew    18:        $(COMPRESS) chrome/annozilla.jar \
                     19:            `find content/annozilla -name CVS -prune -o -name '*.bak' -o -name Thumbs.db -prune -o -name '.#*' -prune -o -type f -print` \
                     20:            `find locale -name CVS -prune -o -name '*.bak' -prune -o -type f -print`
                     21: 
1.12    ! matthew    22: versioncheck:
        !            23:        INSTALL_JS=`perl -n -e 'print $$1 if /<em:version>(.*)<\/em:version>/' install.rdf` ;\
        !            24:        INSTALL_RDF=`perl -n -e 'print $$1 if /const myProductRegVersion = "(.*)";/' install.js` ;\
        !            25:        ABOUT_XUL=`perl -n -e 'print $$1 if /<label id="version" value="(.*)"\/>/' content/annozilla/about/aboutAnnozilla.xul` ;\
        !            26:         perl -e "die 'Version incompatibility $$INSTALL_JS/$$INSTALL_RDF/$$ABOUT_XUL' unless $$INSTALL_JS eq $$INSTALL_RDF and $$INSTALL_JS eq $$ABOUT_XUL"

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>