Diff for /annozilla/src/makefile between versions 1.8 and 1.12

version 1.8, 2005/03/26 11:06:28 version 1.12, 2005/12/29 12:28:30
Line 1 Line 1
SOURCE = content/annozilla/* locale/en-US/annozilla/*XPI = ../downloads/annozilla-latest.xpi
 
 SOURCE = content/annozilla/* \
          content/annozilla/about/* \
          content/annozilla/editor/* \
          content/annozilla/icons/* \
          content/annozilla/prefs/* \
          content/annozilla/prefs/firefox/* \
          locale/en-US/annozilla/* \
          locale/fr-FR/annozilla/*
   
 COMPRESS = perl zip.pl  COMPRESS = perl zip.pl
   
xpi: install.js install.rdf chrome/annozilla.jarxpi: versioncheck install.js install.rdf chrome/annozilla.jar
        $(COMPRESS) ../downloads/annozilla-latest.xpi install.js install.rdf chrome/annozilla.jar        $(COMPRESS) $(XPI) install.js install.rdf chrome/annozilla.jar
   
 chrome/annozilla.jar: $(SOURCE)  chrome/annozilla.jar: $(SOURCE)
        $(COMPRESS) chrome/annozilla.jar `find content/annozilla -name CVS -prune -o -name '*.bak' -o -name Thumbs.db -prune -o -type f -print` `find locale/en-US/annozilla  -name CVS -prune -o -name '*.bak' -o -type f -print`        $(COMPRESS) chrome/annozilla.jar \
             `find content/annozilla -name CVS -prune -o -name '*.bak' -o -name Thumbs.db -prune -o -name '.#*' -prune -o -type f -print` \
             `find locale -name CVS -prune -o -name '*.bak' -prune -o -type f -print`
 
 versioncheck:
         INSTALL_JS=`perl -n -e 'print $$1 if /<em:version>(.*)<\/em:version>/' install.rdf` ;\
         INSTALL_RDF=`perl -n -e 'print $$1 if /const myProductRegVersion = "(.*)";/' install.js` ;\
         ABOUT_XUL=`perl -n -e 'print $$1 if /<label id="version" value="(.*)"\/>/' content/annozilla/about/aboutAnnozilla.xul` ;\
         perl -e "die 'Version incompatibility $$INSTALL_JS/$$INSTALL_RDF/$$ABOUT_XUL' unless $$INSTALL_JS eq $$INSTALL_RDF and $$INSTALL_JS eq $$ABOUT_XUL"

Removed from v.1.8  
changed lines
  Added in v.1.12


FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>