Diff for /annozilla/src/makefile between versions 1.18 and 1.19

version 1.18, 2008/07/14 16:36:41 version 1.19, 2008/08/29 19:41:34
Line 1 Line 1
 COMPRESS = perl zip.pl  COMPRESS = perl zip.pl
 XPI = ../downloads/annozilla-latest.xpi  XPI = ../downloads/annozilla-latest.xpi
   
 HELPFILES = locale/en-US/annozilla/help/creating.xhtml \  
             locale/en-US/annozilla/help/editing.xhtml \  
             locale/en-US/annozilla/help/firefox-editor.png \  
             locale/en-US/annozilla/help/general.xhtml \  
             locale/en-US/annozilla/help/help.css \  
             locale/en-US/annozilla/help/index.xhtml \  
             locale/en-US/annozilla/help/languages.xhtml \  
             locale/en-US/annozilla/help/loading.xhtml \  
             locale/en-US/annozilla/help/preferences.xhtml \  
             locale/en-US/annozilla/help/product-firefox.png \  
             locale/en-US/annozilla/help/product-mozilla.png \  
             locale/en-US/annozilla/help/servers.xhtml \  
             locale/en-US/annozilla/help/viewing.xhtml  
   
 SOURCE = content/annozilla/* \  SOURCE = content/annozilla/* \
          content/annozilla/about/* \           content/annozilla/about/* \
          content/annozilla/editor/* \           content/annozilla/editor/* \
Line 22  SOURCE = content/annozilla/* \ Line 8  SOURCE = content/annozilla/* \
          content/annozilla/prefs/* \           content/annozilla/prefs/* \
          content/annozilla/prefs/firefox/* \           content/annozilla/prefs/firefox/* \
          content/annozilla/prefs/firefox/1.5/* \           content/annozilla/prefs/firefox/1.5/* \
            content/annozilla/resources/* \
          skin/annozilla/* \           skin/annozilla/* \
          skin/annozilla/icons/* \           skin/annozilla/icons/* \
          locale/en-US/annozilla/* \           locale/en-US/annozilla/* \
          locale/fr-FR/annozilla/* \           locale/fr-FR/annozilla/* \
          locale/ja-JP/annozilla/*           locale/ja-JP/annozilla/*
   
xpi: versioncheck install.js install.rdf chrome.manifest chrome/annozilla.jarxpi: versioncheck install.rdf chrome.manifest chrome/annozilla.jar
        $(COMPRESS) $(XPI) install.js install.rdf chrome.manifest chrome/annozilla.jar        $(COMPRESS) $(XPI) install.rdf chrome.manifest chrome/annozilla.jar
   
 chrome/annozilla.jar: chrome $(SOURCE)  chrome/annozilla.jar: chrome $(SOURCE)
         $(COMPRESS) chrome/annozilla.jar \          $(COMPRESS) chrome/annozilla.jar \
Line 47  locale/en-US/annozilla/help/%: ../www/ma Line 34  locale/en-US/annozilla/help/%: ../www/ma
         cp $< $@          cp $< $@
   
 versioncheck:  versioncheck:
        INSTALL_JS=`perl -n -e 'print $$1 if /<em:version>(.*)<\/em:version>/' install.rdf` ;\        INSTALL_RDF=`perl -n -e 'print $$1 if /<em:version>(.*)<\/em:version>/' install.rdf` ;\
        INSTALL_RDF=`perl -n -e 'print $$1 if /const myProductRegVersion = "(.*)";/' install.js` ;\ 
         ABOUT_XUL=`perl -n -e 'print $$1 if /<label id="version" value="(.*)"\/>/' content/annozilla/about/aboutAnnozilla.xul` ;\          ABOUT_XUL=`perl -n -e 'print $$1 if /<label id="version" value="(.*)"\/>/' content/annozilla/about/aboutAnnozilla.xul` ;\
        perl -e "die 'Version incompatibility $$INSTALL_JS/$$INSTALL_RDF/$$ABOUT_XUL' unless $$INSTALL_JS eq $$INSTALL_RDF and $$INSTALL_JS eq $$ABOUT_XUL"        perl -e "die 'Version incompatibility $$INSTALL_RDF/$$ABOUT_XUL' unless $$INSTALL_RDF eq $$ABOUT_XUL"
   

Removed from v.1.18  
changed lines
  Added in v.1.19


FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>