Diff for /annozilla/src/makefile between versions 1.14 and 1.16

version 1.14, 2006/06/27 19:53:42 version 1.16, 2006/12/09 15:37:13
Line 28  SOURCE = content/annozilla/* \ Line 28  SOURCE = content/annozilla/* \
 xpi: versioncheck install.js install.rdf chrome/annozilla.jar  xpi: versioncheck install.js install.rdf chrome/annozilla.jar
         $(COMPRESS) $(XPI) install.js install.rdf chrome/annozilla.jar          $(COMPRESS) $(XPI) install.js install.rdf chrome/annozilla.jar
   
chrome/annozilla.jar: $(SOURCE)chrome/annozilla.jar: chrome $(SOURCE)
         $(COMPRESS) chrome/annozilla.jar \          $(COMPRESS) chrome/annozilla.jar \
             `find content/annozilla -name CVS -prune -o -name '*.bak' -o -name Thumbs.db -prune -o -name '.#*' -prune -o -type f -print` \              `find content/annozilla -name CVS -prune -o -name '*.bak' -o -name Thumbs.db -prune -o -name '.#*' -prune -o -type f -print` \
             `find locale -name CVS -prune -o -name '*.bak' -prune -o -name Thumbs.db -prune -o -type f -print`              `find locale -name CVS -prune -o -name '*.bak' -prune -o -name Thumbs.db -prune -o -type f -print`
   
   build: xpi
           BUILD=`perl -n -e 'print $$1 if /<em:version>(.*)<\/em:version>/' install.rdf` ;\
           mv $(XPI) ../downloads/annozilla-$$BUILD.xpi
   
   chrome:
           mkdir chrome
   
 locale/en-US/annozilla/help/%: ../www/manual/en-US/%  locale/en-US/annozilla/help/%: ../www/manual/en-US/%
         cp $< $@          cp $< $@
   
Line 42  versioncheck: Line 49  versioncheck:
         ABOUT_XUL=`perl -n -e 'print $$1 if /<label id="version" value="(.*)"\/>/' content/annozilla/about/aboutAnnozilla.xul` ;\          ABOUT_XUL=`perl -n -e 'print $$1 if /<label id="version" value="(.*)"\/>/' content/annozilla/about/aboutAnnozilla.xul` ;\
         perl -e "die 'Version incompatibility $$INSTALL_JS/$$INSTALL_RDF/$$ABOUT_XUL' unless $$INSTALL_JS eq $$INSTALL_RDF and $$INSTALL_JS eq $$ABOUT_XUL"          perl -e "die 'Version incompatibility $$INSTALL_JS/$$INSTALL_RDF/$$ABOUT_XUL' unless $$INSTALL_JS eq $$INSTALL_RDF and $$INSTALL_JS eq $$ABOUT_XUL"
   
 install: xpi  
         cp $(XPI) 'c:/Documents and Settings/matthew/Application Data/Firefox/Profiles/default/xrh4z19c.slt/extensions/'  
   

Removed from v.1.14  
changed lines
  Added in v.1.16


FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>